We are currently experiencing problems

Incident Report for Zervicepoint

Resolved

This incident has been resolved.
Posted Dec 13, 2023 - 14:35 UTC

Investigating

We are currently experiencing problems with Zervicepoint Cloud.
The investigation is ongoing. Check back on the statuspage regularly for updates.
Posted Dec 13, 2023 - 11:25 UTC
This incident affected: portal.zervicepoint.com (ProvisioningSystem, ProcessSystem) and Zervicepoint Infrastructure.